注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

过☆客

一颗迷茫的心在3D世界中飘荡...

 
 
 

日志

 
 
关于我

爱宁静,不爱喧闹, 爱奋斗,也爱自由, 爱顺其自然,爱独来独往, 没高学历,不算成功, 没车也没房,但我真诚, 走进你的世界,却不留痕迹, 我是过客,不只是过客...

网易考拉推荐

dyld: Library not loaded: /System/Library/Frameworks/Social.framework/Social  

2015-01-17 16:35:24|  分类: 日积月累-iOS |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
在IOS中用了一下腾讯微博分享的库,引用了Social.framework。然后,在ios5.1的系统上运行就报错了

dyld: Library not loaded: /System/Library/Frameworks/Social.framework/Social
Referenced from: /var/mobile/Applications/3A3020E0-09D7-49DD-96E2-2E0F20C098D2/RacingGenk.app/RacingGenk
Reason: image not found

用的这个Social.framework是ios7.1sdk中的,看这意思貌似这个不支持ios6以前的系统中使用,需要使用ios6以前版本的SDK来用,但电脑上没有6以前的sdk也就没去尝试了。

The social framework isn't available before iOS 6, which explains the problems you're having.
What you need to do is weak link the social framework, which will let you use it on iOS 6 but won't cause pre iOS 6 devices to try to load it. To weak link a library you should select your application's target in XCode, go to the Build Phases tab, and under Link Binary with Libraries make sure that the 'Social.framework' entry is set to Optional rather than Required.

  评论这张
 
阅读(370)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017